Debian: Problems authenticating to ad

by Stoffe Eriksson   Last Updated August 10, 2018 12:00 PM

Our Debian server somehow got disconnected from AD, and I am trying to get it back. I have tried different methods. The one that seems to have worked best is realm. Atleast it says that it has joined the realm. When I try to log in I get access denied. this is from /var/log/auth.log:

Aug 10 13:51:57 WD02 sshd[3876]: Received disconnect from 10.2.0.4: 13: Unable to authenticate [preauth] Aug 10 13:52:04 WD02 sshd[3878]: Invalid user **** from 10.2.0.4 Aug 10 13:52:04 WD02 sshd[3878]: input_userauth_request: invalid user ****[preauth] Aug 10 13:52:08 WD02 sshd[3878]: pam_krb5(sshd:auth): authentication failure; logname=**** uid=0 euid=0 tty=ssh ruser= rhost=10.2.0.4 Aug 10 13:52:08 WD02 sshd[3878]: pam_unix(sshd:auth): check pass; user unknown Aug 10 13:52:08 WD02 sshd[3878]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=10.2.0.4 Aug 10 13:52:08 WD02 sshd[3878]: pam_sss(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=10.2.0.4 user=ster Aug 10 13:52:08 WD02 sshd[3878]: pam_sss(sshd:auth): received for user ****: 10 (User not known to the underlying authentication module) Aug 10 13:52:10 WD02 sshd[3878]: Failed password for invalid user **** from 10.2.0.4 port 61928 ssh2

after i've been at this for a while it is now possible to login with the user i have experimented with, but only if I write the username ***@domain.name. This only works for this user however, everyone else gets denied, even if they login with @domain.name

Do anyone have any idea? I am not sure what config-files or other logs I should provide, but will happily do so if asked to.

Regards Stoffe Eriksson



Related Questions


sssd can't save user. Missing uid

Updated March 16, 2017 17:00 PM


vsFTPd authenticating with SSSD

Updated April 03, 2015 00:00 AM


Linux Mint 18 - AD Users cannot login to GUI

Updated April 14, 2017 11:00 AM