Bluetooth not working in 20.04 - fine in 19.10

by stdunbar   Last Updated June 30, 2020 03:02 AM - source

I have a Dell Laptop with an Intel AX200 WiFi/Bluetooth adapter. This combo was working fine in 19.10. But any attempt to connect now claims to connect but does not. I'm using Cinnamon as a desktop. /usr/bin/blueman-tray regularly crashes and I do send the bug report.

I have:

lspci -knn | grep Net -A3; lsusb:

09:00.0 Ethernet controller [0200]: Intel Corporation I210 Gigabit Network Connection [8086:1533] (rev 03)
    Subsystem: Device [1d2d:f017]
    Kernel driver in use: igb
    Kernel modules: igb
--
3b:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX200 [8086:2723] (rev 1a)
    Subsystem: Intel Corporation Wi-Fi 6 AX200 [8086:0084]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi
Bus 009 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 010 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 007 Device 002: ID 0bda:2171 Realtek Semiconductor Corp. BillBoard Device
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 003: ID 046d:0821 Logitech, Inc. HD Webcam C910
Bus 005 Device 002: ID 047f:c012 Plantronics, Inc. Plantronics .Audio 628 USB
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0d8c:0022 C-Media Electronics, Inc. USB Advanced Audio Device
Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 27c6:5395 Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader
Bus 001 Device 002: ID 8087:0029 Intel Corp. 
Bus 001 Device 004: ID 0c45:671d Microdia Integrated_Webcam_HD
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg | grep -i blue:

[    4.658409] Bluetooth: Core ver 2.22
[    4.658436] Bluetooth: HCI device and connection manager initialized
[    4.658439] Bluetooth: HCI socket layer initialized
[    4.658444] Bluetooth: L2CAP socket layer initialized
[    4.658446] Bluetooth: SCO socket layer initialized
[    4.803879] Bluetooth: hci0: Firmware revision 0.0 build 128 week 11 2020
[    6.361217] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    6.361218] Bluetooth: BNEP filters: protocol multicast
[    6.361221] Bluetooth: BNEP socket layer initialized
[   19.087978] Bluetooth: RFCOMM TTY layer initialized
[   19.087982] Bluetooth: RFCOMM socket layer initialized
[   19.087985] Bluetooth: RFCOMM ver 1.11

and lspci -k -s 3b:00.0

3b:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)
    Subsystem: Intel Corporation Wi-Fi 6 AX200
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

Again, this was working as recently as Ubuntu 19.10. I've seen a few posts but I'm unable to get it back. System is fully up to date as of this writing. Any directions?



Related Questions


Wi-Fi and Bluetooth constantly disconnecting

Updated June 23, 2020 18:02 PM

ubuntu 18.04 having problems with wifi and bluetooth

Updated December 07, 2018 20:02 PM

Wifi adapter not found (Intel wifi 6 AX200)

Updated June 09, 2020 12:02 PM


iwlwifi driver issue with ubuntu 20.4

Updated May 26, 2020 04:02 AM